phpMyAdmin versi 3.4.4 dan 3.3.10.4 dirilis untuk Tutup Lubang Keamanan

H-Online.Com – Para pengembang phpMyAdmin telah mengumumkan rilis versi 3.4.4 dan 3.3.10.4 perangkat administrasi database yang mereka kembangkan itu. Berdasarkan masukan seputar keamanan, update perawatan dan keamanan ini menutup lubang (CVE-2011-3181) pda fitur Tracking yang dapat menyebabkan kerentanan multiple cross-site scripting (XSS).

Kelemahan tersebut ditemukan oleh Norman Hippert dan hal tersebut menyebabkan sanitasi yang tidak tepat ketika input dimasukkan ke dalam tabel, kolom dan index. Jika sebuah serangan berhasil, seorang penyerang dapat masuk via phpMyAdmin. Versi 3.3.0 hingga 3.4.3.2 memiliki kelemahan itu dan para pengembang berupaya dengan serius memperbaikinya. Mengupdate ke phpMyAdmin versi 3.3.10.4 atau 3.4.4 akan dapat memperbaiki kelemahan tersebut. Atau alternatif lain, pengguna dapat melakukan patch pada phpMyAdmin yang mereka gunakan.

Informasi lebih jauh tentang update dapat dibaca di pengumuman rilis  3.4.4 dan 3.3.10.4 serta di saran keamanan proyek tersebut. Versi 3.4.4. dan 3.3.10.4 dapat diunduh dari situs proyek tersebut. phpMyAdmin berlisensi GPLv2.

Terjemah Bebas oleh Pengelola Blog https://tanyarezaervani.wordpress.com