Tanya :

Adakah cara mengetahui dependencies sebuah paket di sistem kita dengan mudah ?

Jawab :

Ada,

Salah satunya adalah dengan apt-redepends

Install dulu dengan

sudo apt-get install apt-rdepends

Setelah terinstall anda dapat menggunakannya dengan perintah

sudo apt-rdepends <nama paket>

Contoh :

Saya ingin mengetahui dependencies dari apache2 :

rezaervani@rezaervani-laptop:~/Documents/oprek$ sudo apt-rdepends apache2
Reading package lists... Done
Building dependency tree 
Reading state information... Done
apache2
 Depends: apache2-mpm-event (= 2.2.14-5ubuntu8)
 Depends: apache2-mpm-itk (= 2.2.14-5ubuntu8)
 Depends: apache2-mpm-prefork (= 2.2.14-5ubuntu8)
 Depends: apache2-mpm-worker (= 2.2.14-5ubuntu8)
 Depends: apache2.2-common (= 2.2.14-5ubuntu8)
apache2-mpm-event
 Depends: apache2.2-bin (= 2.2.14-5ubuntu8)
 Depends: apache2.2-common (= 2.2.14-5ubuntu8)
apache2.2-bin
 Depends: libapr1 (>= 1.3.3)
 Depends: libaprutil1 (>= 1.3.2+dfsg)
 Depends: libaprutil1-dbd-freetds
 Depends: libaprutil1-dbd-mysql
 Depends: libaprutil1-dbd-odbc
 Depends: libaprutil1-dbd-pgsql
 Depends: libaprutil1-dbd-sqlite3
 Depends: libaprutil1-ldap
 Depends: libc6 (>= 2.4)
 Depends: libcap2 (>= 2.10)
 Depends: libldap-2.4-2 (>= 2.4.7)
 Depends: libpcre3 (>= 7.7)
 Depends: libssl0.9.8 (>= 0.9.8k-1)
 Depends: zlib1g (>= 1:1.1.4)
libapr1
 Depends: libc6 (>= 2.4)
 Depends: libuuid1 (>= 2.16)
libc6
 Depends: debconf (>= 0.5)
 Depends: debconf-2.0
 Depends: findutils (>= 4.4.0-2ubuntu2)
 Depends: libc-bin (= 2.11.1-0ubuntu7)
 Depends: libgcc1
 Depends: tzdata
debconf
 Depends: debconf-english
 Depends: debconf-i18n
 PreDepends: perl-base (>= 5.6.1-4)
debconf-english
 Depends: debconf
debconf-i18n
 Depends: debconf
 Depends: liblocale-gettext-perl
 Depends: libtext-charwidth-perl
 Depends: libtext-iconv-perl
 Depends: libtext-wrapi18n-perl
liblocale-gettext-perl
 Depends: libc6 (>= 2.2)
 PreDepends: perl-base (>= 5.10.0-24ubuntu4)
 PreDepends: perlapi-5.10.0
perl-base
 PreDepends: dpkg (>= 1.14.20)
 PreDepends: libc6 (>= 2.11)
dpkg
 PreDepends: coreutils (>= 5.93-1)
 PreDepends: libc6 (>= 2.11)
 PreDepends: lzma
coreutils
 PreDepends: libacl1 (>= 2.2.11-1)
 PreDepends: libattr1 (>= 2.4.41-1)
 PreDepends: libc6 (>= 2.11)
 PreDepends: libselinux1 (>= 1.32)
libacl1
 Depends: libattr1 (>= 2.4.41-1)
 Depends: libc6 (>= 2.4)
libattr1
 Depends: libc6 (>= 2.4)
libselinux1
 Depends: libc6 (>= 2.8)
lzma
 Depends: libc6 (>= 2.4)
 Depends: libgcc1 (>= 1:4.1.1)
 Depends: libstdc++6 (>= 4.4.0)
libgcc1
 Depends: gcc-4.4-base (= 4.4.3-4ubuntu5)
 Depends: libc6 (>= 2.2.4)
gcc-4.4-base
libstdc++6
 Depends: gcc-4.4-base (= 4.4.3-4ubuntu5)
 Depends: libc6 (>= 2.4)
 Depends: libgcc1
perlapi-5.10.0
libtext-charwidth-perl
 Depends: libc6 (>= 2.1.3)
 Depends: perl-base (>= 5.10.0-24ubuntu4)
 Depends: perlapi-5.10.0
libtext-iconv-perl
 Depends: libc6 (>= 2.1.3)
 Depends: perl-base (>= 5.10.0-24ubuntu4)
 Depends: perlapi-5.10.0
libtext-wrapi18n-perl
 Depends: libtext-charwidth-perl
debconf-2.0
findutils
 PreDepends: libc6 (>= 2.7)
libc-bin
tzdata
 Depends: debconf (>= 0.5)
 Depends: debconf-2.0
libuuid1
 Depends: libc6 (>= 2.4)
 Depends: passwd
passwd
 Depends: debianutils (>= 2.15.2)
 Depends: libc6 (>= 2.4)
 Depends: libpam-modules
 Depends: libpam0g (>= 0.99.7.1)
 Depends: libselinux1 (>= 1.32)
debianutils
 Depends: sensible-utils
 PreDepends: libc6 (>= 2.7)
sensible-utils
libpam-modules
 Depends: base-files (>= 5.0.0ubuntu6)
 PreDepends: debconf (>= 0.5)
 PreDepends: debconf-2.0
 PreDepends: libc6 (>= 2.8)
 PreDepends: libdb4.8
 PreDepends: libpam0g (>= 1.1.0)
 PreDepends: libselinux1 (>= 2.0.85)
base-files
 Depends: base-passwd (>= 2.0.3.4)
 Depends: libpam-modules (>= 0.79-3ubuntu3)
 PreDepends: awk
base-passwd
 Depends: libc6 (>= 2.8)
awk
libdb4.8
 Depends: libc6 (>= 2.4)
libpam0g
 Depends: debconf (>= 0.5)
 Depends: debconf-2.0
 Depends: libc6 (>= 2.8)
libaprutil1
 Depends: libapr1 (>= 1.2.7)
 Depends: libc6 (>= 2.4)
 Depends: libdb4.8
 Depends: libexpat1 (>= 1.95.8)
 Depends: libuuid1 (>= 2.16)
libexpat1
 Depends: libc6 (>= 2.4)
libaprutil1-dbd-freetds
 Depends: libaprutil1 (= 1.3.9+dfsg-3build1)
 Depends: libc6 (>= 2.4)
 Depends: libsybdb5 (>= 0.63)
libsybdb5
 Depends: freetds-common
 Depends: libc6 (>= 2.8)
freetds-common
libaprutil1-dbd-mysql
 Depends: libaprutil1 (= 1.3.9+dfsg-3build1)
 Depends: libc6 (>= 2.3.6-6~)
 Depends: libmysqlclient16 (>= 5.1.21-1)
libmysqlclient16
 Depends: libc6 (>= 2.4)
 Depends: mysql-common (>= 5.1.41-3ubuntu12)
 Depends: zlib1g (>= 1:1.1.4)
mysql-common
zlib1g
 Depends: libc6 (>= 2.4)
libaprutil1-dbd-odbc
 Depends: libaprutil1 (= 1.3.9+dfsg-3build1)
 Depends: libc6 (>= 2.4)
 Depends: unixodbc (>= 2.2.11)
unixodbc
 Depends: libc6 (>= 2.4)
 Depends: libltdl7 (>= 2.2.6a)
 Depends: libreadline6
 Depends: odbcinst1debian1 (>= 2.2.11-3)
libltdl7
 Depends: libc6 (>= 2.4)
libreadline6
 Depends: libc6 (>= 2.11~20100104-0ubuntu5)
 Depends: libncurses5 (>= 5.6+20071006-3)
 Depends: readline-common
libncurses5
 Depends: libc6 (>= 2.4)
readline-common
 Depends: dpkg (>= 1.15.4)
 Depends: install-info
install-info
 Depends: libc6 (>= 2.4)
odbcinst1debian1
 Depends: libc6 (>= 2.4)
 Depends: libltdl7 (>= 2.2.6a)
 Depends: odbcinst
odbcinst
 Depends: libc6 (>= 2.4)
 Depends: libltdl7 (>= 2.2.6a)
 Depends: odbcinst1debian1 (>= 2.2.11-3)
libaprutil1-dbd-pgsql
 Depends: libaprutil1 (= 1.3.9+dfsg-3build1)
 Depends: libc6 (>= 2.3.6-6~)
 Depends: libpq5 (>= 8.4~0cvs20090328)
libpq5
 Depends: libc6 (>= 2.4)
 Depends: libcomerr2 (>= 1.01)
 Depends: libgssapi-krb5-2 (>= 1.7dfsg~beta1)
 Depends: libkrb5-3 (>= 1.6.dfsg.2)
 Depends: libldap-2.4-2 (>= 2.4.7)
 Depends: libssl0.9.8 (>= 0.9.8k-1)
libcomerr2
 Depends: libc6 (>= 2.3.6-6~)
libgssapi-krb5-2
 Depends: libc6 (>= 2.7)
 Depends: libcomerr2 (>= 1.34)
 Depends: libk5crypto3 (>= 1.8+dfsg)
 Depends: libkeyutils1
 Depends: libkrb5-3 (= 1.8.1+dfsg-2)
 Depends: libkrb5support0 (>= 1.7dfsg~beta2)
libk5crypto3
 Depends: libc6 (>= 2.4)
 Depends: libkeyutils1
 Depends: libkrb5support0 (>= 1.7dfsg~beta2)
libkeyutils1
 Depends: libc6 (>= 2.1.3)
libkrb5support0
 Depends: libc6 (>= 2.3.4)
 Depends: libkeyutils1
libkrb5-3
 Depends: libc6 (>= 2.9)
 Depends: libcomerr2 (>= 1.34)
 Depends: libk5crypto3 (>= 1.8+dfsg)
 Depends: libkeyutils1
 Depends: libkrb5support0 (= 1.8.1+dfsg-2)
libldap-2.4-2
 Depends: libc6 (>= 2.4)
 Depends: libgnutls26 (>= 2.7.14-0)
 Depends: libgssapi-krb5-2 (>= 1.7+dfsg)
 Depends: libsasl2-2
libgnutls26
 Depends: libc6 (>= 2.8)
 Depends: libgcrypt11 (>= 1.4.2)
 Depends: libtasn1-3 (>= 1.6-0)
 Depends: zlib1g (>= 1:1.1.4)
libgcrypt11
 Depends: libc6 (>= 2.4)
 Depends: libgpg-error0 (>= 1.6)
libgpg-error0
 Depends: libc6 (>= 2.1.3)
libtasn1-3
 Depends: libc6 (>= 2.4)
libsasl2-2
 Depends: libc6 (>= 2.4)
 Depends: libdb4.8
libssl0.9.8
 Depends: debconf (>= 0.5)
 Depends: debconf-2.0
 Depends: libc6 (>= 2.7)
 Depends: zlib1g (>= 1:1.1.4)
libaprutil1-dbd-sqlite3
 Depends: libaprutil1 (= 1.3.9+dfsg-3build1)
 Depends: libc6 (>= 2.3.6-6~)
 Depends: libsqlite3-0 (>= 3.6.22)
libsqlite3-0
 Depends: libc6 (>= 2.4)
libaprutil1-ldap
 Depends: libaprutil1 (= 1.3.9+dfsg-3build1)
 Depends: libc6 (>= 2.3.6-6~)
 Depends: libldap-2.4-2 (>= 2.4.7)
libcap2
 Depends: libattr1 (>= 2.4.41-1)
 Depends: libc6 (>= 2.8)
libpcre3
 Depends: libc6 (>= 2.4)
apache2.2-common
 Depends: apache2-utils
 Depends: apache2.2-bin (= 2.2.14-5ubuntu8)
 Depends: libmagic1
 Depends: lsb-base
 Depends: mime-support
 Depends: perl
 Depends: procps
apache2-utils
 Depends: libapr1 (>= 1.2.7)
 Depends: libaprutil1 (>= 1.2.7+dfsg)
 Depends: libc6 (>= 2.4)
 Depends: libssl0.9.8 (>= 0.9.8k-1)
libmagic1
 Depends: libc6 (>= 2.8)
 Depends: zlib1g (>= 1:1.1.4)
lsb-base
 Depends: ncurses-bin
 Depends: sed
ncurses-bin
 PreDepends: libc6 (>= 2.4)
 PreDepends: libncurses5 (>= 5.6+20071006-3)
sed
 Depends: dpkg (>= 1.15.4)
 Depends: install-info
 PreDepends: libc6 (>= 2.4)
 PreDepends: libselinux1 (>= 1.32)
mime-support
perl
 Depends: libbz2-1.0
 Depends: libc6 (>= 2.11)
 Depends: libdb4.8
 Depends: libgdbm3 (>= 1.8.3)
 Depends: perl-base (= 5.10.1-8ubuntu2)
 Depends: perl-modules (>= 5.10.1-8ubuntu2)
 Depends: zlib1g (>= 1:1.2.3.3.dfsg)
libbz2-1.0
 Depends: libc6 (>= 2.4)
libgdbm3
 Depends: dpkg (>= 1.15.4)
 Depends: install-info
 Depends: libc6 (>= 2.1.3)
perl-modules
 Depends: perl (>= 5.10.1-1)
procps
 Depends: libc6 (>= 2.4)
 Depends: libncurses5 (>= 5.6+20071006-3)
 Depends: lsb-base (>= 3.0-10)
 Depends: upstart-job
upstart-job
apache2-mpm-itk
 Depends: apache2.2-bin (= 2.2.14-5ubuntu8)
 Depends: apache2.2-common (= 2.2.14-5ubuntu8)
apache2-mpm-prefork
 Depends: apache2.2-bin (= 2.2.14-5ubuntu8)
 Depends: apache2.2-common (= 2.2.14-5ubuntu8)
apache2-mpm-worker
 Depends: apache2.2-bin (= 2.2.14-5ubuntu8)
 Depends: apache2.2-common (= 2.2.14-5ubuntu8)

Selamat mencoba

Iklan